Leçons de niveau 16

Birt/Un premier rapport

Une page de Wikiversité.
Sauter à la navigation Sauter à la recherche
Début de la boite de navigation du chapitre
Un premier rapport
Icône de la faculté
Chapitre no 3
Leçon : Birt
Chap. préc. :Téléchargement et Installation
Chap. suiv. :Sources de données
fin de la boite de navigation du chapitre
Icon falscher Titel.svg
En raison de limitations techniques, la typographie souhaitable du titre, « Birt : Un premier rapport
Birt/Un premier rapport
 », n'a pu être restituée correctement ci-dessus.

Pour générer un rapport de données sous Birt il y a au préalable plusieurs manipulations à effectuer.


Schéma création rapport.jpg


Création du projet[modifier | modifier le wikicode]

  • Il faut tout d’abord créer un projet dans lequel l'utilisateur pourra stocker autant de rapports que souhaité (il suffit de nommer le projet et de lui spécifier un emplacement de stockage).


Sélectionner File => New => Project.
Dans l’onglet Birt Intelligence and Reporting Tools , sélectionner Report project.




  • Une fois le projet créé, des rapports peuvent être construits à partir de sources de données multiples.


Sélectionner File => New => Report.


  • Plusieurs trames sont à disposition, sélectionner la trame My First Report pour cette leçon.

Création de la Data source[modifier | modifier le wikicode]

  • Quelles que soient les sources de données utilisées (Sources de données), il faut les lier entre elles et au projet en cours par le biais de l'outil "Data source". Selon le format de la base de données (BDD), différents paramétrages devront être effectués. Dans l'exemple suivant, la BDD sera, pour des raisons de simplicité de compréhension, au format XML.


Dans l'onglet Data Explorer, sélectionner Data source puis New Data source.
Sélectionner le type de données XML puis cliquer sur Next




  • Entrer l’URL du fichier XML (base de donnée) puis tester la connexion entre ce fichier et Birt par une commande standard de type Ping.


Saisir l'adresse du fichier puis tester la connexion en cliquant sur Test Connection.
Cliquer sur OK




  • La connexion correctement effectuée cliquer sur « Finish », votre Data Source est prête à être exploitée.

Création du Data set[modifier | modifier le wikicode]

  • La création D'un Data set permet à Birt d’extraire de la base de données les informations demandées par l'utilisateur pour la création de son rapport.


Cliquer sur Data set puis New Data set.
Sélectionner la Data source utilisée puis la nommer.




  • Sélection des données requises par l'utilisateur.


Sélectionner Row puis ajouter.
Cliquer sur Ok.



Sélectionner les données puis ajouter




  • Vérifier que les données sélectionnées apparaissent de la même façon que sur la base de données.


Cliquer sur Show sample data puis vérifier la structure des données.


Finalisation et export du rapport[modifier | modifier le wikicode]

Finalisation[modifier | modifier le wikicode]

  • L'utilisateur peut désormais organiser ses données selon ses besoins. Pour cela il suffit de faire glisser/déposer les différentes données.


Dans l'onglet Data Explorer, Sélectionner le Data set créé puis glisser les différentes données.
Double cliquer sur le titre de la colonne pour le renommer.





  • L'utilisateur peut prévisualiser le résultat du rapport et ainsi le modifier à sa convenance (la mise en page du rapport est détaillée au chapitre 6).


Sélectionner Preview.




Export[modifier | modifier le wikicode]

  • Une fois les données organisées, Birt permet d'exporter le rapport sous différents formats.


Sélectionner View report puis le format souhaité par l'utilisateur.
Voici un exemple de premier rapport Birt sans aucune mise en page (voir chapitre 6).