« SPARQL Protocol and RDF Query Language/Travail pratique/Initiation à Eclipse » : différence entre les versions

Aller à la navigation Aller à la recherche
aucun résumé de modification
Aucun résumé des modifications
Il vous faut avoir fait au moins le TP PHP.
 
=== A savoir pouravant de commencer ===
Il n’y a que 2 débuggeursdébogueurs pour PHP :
*Zend qui est intégré dans la suite de développement payante Zend (à condition d’avoir les serveurs de productions également avec Zend sinon...bugs d’incompatibilités à prévoir)
*XDebug qui est gratuit mais qui est moins simple à installer
== Installation ==
 
=== DébuggeurDébogueur : XDebug ===
Il y a autant de manières d'installer XDebug qu'il y a de version de Linux.
 
Pour identifier, si l'installation suivante peut fonctionner avec votre version de linuxLinux, vous devez d'abord connaitreconnaître la version que vous utilisez avec la commande suivante.
<source lang="bash">
lsb_release -a
</source>
 
L'installation suivante sera faite avec la version Ubuntu 10.04.3. Si ce n'est pas votre version n'hésitez pas à comparer cette installation avec les résultats dans Google quand vous recherchez :le nom de votre distribution linuxLinux avec sa version et XdebugXDebug .
 
==== Ubuntu 10.04.3 ====
</source>
 
On fabrique le répertoire bin dans notre repertoirerépertoire home qui sera utilisé pour lancer Eclipse :
<source lang="bash">
mkdir ~/bin
 
Pour finir, on va créer un raccourcie pour le mettre sur notre bureau :
#Cliquercliquer bouton droit sur votre bureau
#Créercréer raccourcie (ou create launcher)
#Indiquerindiquer le nom : Eclipse
#Indiquerindiquer le chemin du script (command) : /home/<your username>/opt/eclipse/eclipse
#Cliquercliquer sur l'icône pour indiquer le chemin du script de l'icône d'Eclipse : /home/<your username>/opt/eclipse/eclipse/icon.xpm
# cliquer sur OK
 
Vous pouvez maintenant double cliquer sur l'iconel’icône Eclipse sur votre bureau.
 
Eclipse s'ouvre et vous demande de préciser votre espace de travail, '''indiquer un autre répertoire que ~/projets'''. Cela évite un certain nombre de problèmes de configuration.
=== Configurer la source des mises-à-jour et des plugins d'Eclipse ===
Dans Eclipse :
# Aller dans le menu : Help > Install New Software .
# cliquer que le bouton "Add..." .
# renseigner les champs avec le nom : Indigo et l'adresse http://download.eclipse.org/releases/indigo.
 
Vous pouvez maintenant installer les plugins PHP et Web.
 
Dans Eclipse :
# Aller dans le menu : Help > Install New Software .
# Choisir le site (Work with) : "Indigo -- http://download.eclipse.org/releases/.
# attendreAttendre que la liste soit mise à jour (attendez que le mot pending disparaisse...).
#allerAller ensuite dans langages de programmation .
#cocherCocher la liste PHP Development Tools (PDT).
#Cliquer sur suivant deux fois.
#cocherCocher Accepter les licences.
#cliquerCliquer sur terminer.
 
Après l'installation, Eclipse vous demande de redémarrer :
=== Installer le plugin Web ===
 
# Aller dans le menu : Help > Install New Software .
# Choisir le site (Work with) : "Indigo -- http://download.eclipse.org/releases/ .
# attendreAttendre que la liste soit mise à jour (attendez que le mot pending disparaisse...).
#aller Aller ensuite dans "Web,XML,JavaEE...".
#cocher Cocher "Eclipse Web Developer Tools".
# Cliquer sur suivant deux fois.
#cocher Cocher Accepter les licences.
#cliquer Cliquer sur terminer.
 
Après l'installation, Eclipse vous demande de redémarrer :
* cliquerCliquer sur "redémarrer maintenant".
 
== Ouvrir votre projet PHP dans Eclipse ==
Nous avons dans le projet précédent utilisé PHPUnit et créer unecréé l'arborescence àde fichier undu projet nommé MonCV.
Nous allons ouvrir ce projet et le configurer.
 
#Ouvrir Eclipse.
#Menu Fichier > Nouveau projet.
#Ouvrer PHP > projet PHP.
 
La boite de dialogue nouveau projet s'ouvre.
#Donner un nom au projet : MonCv.
#Cocher : Créercréer un projet de sources existantes.
#Rechercher la racine du répertoire créer dans le TP précédent : ~/projets/moncv .
#cliquer sur Terminer (Finish).
 
== Configurer la construction du projet ==
</source>
 
Maintenant, on indique les moments d’exécution :
#Aller dans l'onglet RafraichirRafraîchir (Refresh)
#Cocher la case rafraichirrafraîchir les ressources (Refresh ressouces upon each completion)
#Cocher : Espace de travail en entier (The entire Workspace)
#Aller maintenant dans l'onglet Options (Build Options)
Cliquer finalement sur le bouton OK pour refermer la boite de dialogue.
 
== Configurer le débugguagedébogueur ==
=== Indiquer le serveur utiliser pour débugger ===
Nous utiliserons le serveur Web que nous avons installé dans un précédent TP pour débuguerdéboguer notre projet.
 
#Via le Menu : Window > Preferences
##Dans chemin sur le serveur mettre : /var/www/moncv
##Cocher chemin dans l'espace de travail
##Trouver la racine des sources, c'est-à-dire le répertoire src. Vous devez avoir comme résultat : MonCV/src
#Cliquer sur OK jusqu'à ce que toutes les boites de dialogues soient fermées
 
=== Indiquer le débuggeurdébogueur ===
# Via le Menu : Window > Preferences
# Aller dans le Menu : Window > Preferences
Un point d'arrêt est un point placé à un endroit spécifique d'un programme qui permet d'indiquer à un débogueur d'arrêter l'exécution lorsqu'il atteindra cet endroit.
 
C'est très pratique pour voir à cet endroit la valeur des variables ou encore pour commencer à faire du de l'exécution pas à pas dans le code.<br/>
Le pas à pas permet d'avancer dans le code "commande par commande". Le pas à pas permet de voir exactement ce qui exécuter par le programme.
 
Pour insérer un point d'arrêt, il suffit de double cliquer sur le numéro de ligne où vous souhaitez que le programme s'arrête. Un point bleu doit apparaitreapparaître dans la marge ce qui indique le point d'arrêt.
 
'''Exercice''' : double cliquer sur le numéro de ligne où la fonction phpinfo se trouve.
Ce point d'arrêt nous sera utile dans l'exercice suivant.
 
=== Créer un profil de débuggeurdébogage ===
 
Un site Web est composé de plusieurs fichiers PHP qui peuvent être autant de point d'entrée dans votre site.
Si vous débuguerdébuggez une page php particulière, il vous faudra créer un profil de débuggage pour cette page.
A chaque fois que vous voudrez débugger une page, vous pourrez réutiliser le profil de cette page que vous avez créé.
 
Si ce n'est pas le cas, indiquez XDebug et le serveur moncv}}
 
=== débugger Débugger===
 
Eclipse a plusieurs modes d'affichage. Il y en a un pour PHP et un pour Débuggerdébugger. Eclipse vous demandera souvent de passer d'un mode à un autre automatiquement.
 
Pour revenir manuellement à un de ces modes, vous pouvez faire menu : Window > Open Perspective > PHP ou Debug.
700

modifications

Menu de navigation